Map Database  •  FAQ  •  RSS  •  Register  •  Login

Building KamRemake

<<

hopst

Serf

Posts: 7

Joined: 31 May 2018, 23:58

Post 01 Jun 2018, 00:12

Building KamRemake

Hi, could yu please help me how to build the project? im not so familiar with pascal or lazarus, i know the page that talks about building it but the lazarus version it mentions cannot be found now, so i used 2.4.4 2.4.2 2.4.0 and the newest but all gives the same error on build (btw it is the git master branch) in the newest version the error is the following : KM_Settings.pas(5,38) Fatal: Cannot find System.UITypes used by KM_Settings. could you help how to solve it pls? thx
<<

Krom

User avatar

KaM Remake Developer

Posts: 3194

Joined: 09 May 2006, 22:00

Location: Russia

KaM Skill Level: Fair

Post 01 Jun 2018, 05:24

Re: Building KamRemake

I haven't build Remake for Lazarus for a long time..

Generally you would need to remove units unknown to Lazarus and patch up what they were used for. See other parts of code where UITypes is used - maybe there it is wrapped into IFDEF WDC and there's a IFDEF LAZARUS alternative next to it.

Also you could try Delphi Starter, which is free, iirc.
Knights Province at: http://www.knightsprovince.com
KaM Remake at: http://www.kamremake.com
Original MBWR/WR2/AFC/FVR tools at: http://krom.reveur.de
<<

sado1

User avatar

Moorbach's Guard

Posts: 1376

Joined: 21 May 2012, 19:13

KaM Skill Level: Skilled

Post 01 Jun 2018, 05:53

Re: Building KamRemake

It should compile with Delphi on Windows right away, Lazarus will not work out of the box. Thibmo did quite some work on porting Remake to work on Lazarus and Linux again, but I think it was never merged with master branch.
<<

hopst

Serf

Posts: 7

Joined: 31 May 2018, 23:58

Post 01 Jun 2018, 06:18

Re: Building KamRemake

thx, ill try.
<<

Rey

User avatar

KaM Remake Developer

Posts: 204

Joined: 12 Oct 2016, 07:41

Location: Moscow

KaM Skill Level: Fair

Post 01 Jun 2018, 16:10

Re: Building KamRemake

Version from Krom's repo is not compatible with lazarus, unfortunally, but you can try my repository where you can build version with Lazarus, especially if you want to try the latest release.
Compilation with Lazarus and Delphi will make a little bit different versions, but the difference is quite tiny, they are almost same. Anyway released beta versions are compiled with Delphi.
<<

hopst

Serf

Posts: 7

Joined: 31 May 2018, 23:58

Post 01 Jun 2018, 23:36

Re: Building KamRemake

yeah that would be great, because i dont have a delphi ide, can you link me your repo pls?
<<

Rey

User avatar

KaM Remake Developer

Posts: 204

Joined: 12 Oct 2016, 07:41

Location: Moscow

KaM Skill Level: Fair

Post 02 Jun 2018, 03:21

Re: Building KamRemake

<<

hopst

Serf

Posts: 7

Joined: 31 May 2018, 23:58

Post 03 Jun 2018, 03:30

Re: Building KamRemake

I tried this one with lazarus, this threw that error,by the way which delphi ide you use? i only saw enterprise ones, but i wouldn't like to pay a fortune for them :). sorry for being noob.
<<

Rey

User avatar

KaM Remake Developer

Posts: 204

Joined: 12 Oct 2016, 07:41

Location: Moscow

KaM Skill Level: Fair

Post 03 Jun 2018, 06:16

Re: Building KamRemake

AHH, sorry, I forgot to say that you need FPC 3.0.0 compiler for Lazarus. It's coming within old Lazarus 1.6.2 version. Or you can install newer Laz version, but set it up with separately installed FPC 3.0.0 compiler.

I use Delphi Berlin. Delphi Tokio had some bugs in it, so compiled project was not really working as expected. May be they fixed those bugs and now it's fine.

There is a free version of Delphi - Delphi Starter: https://www.embarcadero.com/products/delphi/starter/free-download
<<

hopst

Serf

Posts: 7

Joined: 31 May 2018, 23:58

Post 03 Jun 2018, 11:53

Re: Building KamRemake

i got the following error with lazarus 1.6.2 with fpc 3.0.0: KM_Networking.pas(12,5) Fatal: Cannot find KM_NetAuthSecure used by KM_Networking.
oh sorry i read the comment XD, is that a problem that i dont have that file? and disabled it?
it compiled thank you.but it threw a data corruption error when i run it.
<<

sado1

User avatar

Moorbach's Guard

Posts: 1376

Joined: 21 May 2012, 19:13

KaM Skill Level: Skilled

Post 03 Jun 2018, 12:37

Re: Building KamRemake

hopst wrote:i got the following error with lazarus 1.6.2 with fpc 3.0.0: KM_Networking.pas(12,5) Fatal: Cannot find KM_NetAuthSecure used by KM_Networking.
oh sorry i read the comment XD, is that a problem that i dont have that file? and disabled it?
it compiled thank you.but it threw a data corruption error when i run it.

https://github.com/reyandme/kam_remake/ ... ompilation There is some useful info here too, also about that netauth module. You don't necessarily need it I think.
<<

hopst

Serf

Posts: 7

Joined: 31 May 2018, 23:58

Post 03 Jun 2018, 19:04

Re: Building KamRemake

thx guys that did it, it runs now.i will try to make some modifications now :)
<<

hopst

Serf

Posts: 7

Joined: 31 May 2018, 23:58

Post 04 Jun 2018, 03:01

Re: Building KamRemake

sorry but i have one more question, how does your repo compares to https://github.com/Kromster80/kam_remake? because i noticed i could not use shift to fill school building's unit queue in one click, does that have features that are not present in your version or the specific feature was dropped?

edit: oh i see now in the source, it is right click now.
<<

sado1

User avatar

Moorbach's Guard

Posts: 1376

Joined: 21 May 2012, 19:13

KaM Skill Level: Skilled

Post 04 Jun 2018, 14:55

Re: Building KamRemake

Rey's repo is the current development version, which will hopefully become the new release in a matter of months. Krom (along with Lewin) was the original Remake developer, but he has his new playtoy now and his role in the Remake project was reduced to more of a consulting one :) so, Krom's repo pretty much stopped getting changes a year ago or so.

Return to General / Questions

Who is online

Users browsing this forum: No registered users and 8 guests